Server Totals
Mikona - (2)
Elysia - (1)
Wilderness - (1)
Ferrell - (0)
Le'Or - (0)
M'Chek - (0)
Deglos - (0)
Visimontium - (0)
Underdark - (0)
Total players: 4
Gallery

Links Menu

Fixing issues with Vista/7 and NWN

Moderators: Nighthawk4, Dungeon Masters

Fixing issues with Vista/7 and NWN

PostAuthor: Aperion » Sun Feb 21, 2010 9:37 pm

If you are having stability issues OR are installing NWN on Vista or Windows 7, here's some more useful information. First and foremost, to get the game to work at all, this is the absolute minimum you must do:
-Update to 1.69.
-Install all Avlis haks.
-Set ALL executables in your NWN folder to run as Administrator. All of them.
-Make sure you use up to date drivers and all mandatory patches for your OS.

At this point, NWN should work. However, not all things are equal, and different machines with different hardware can affect NWN in different ways. Some Vista/7 machines play NWN perfectly. Others crash all to hell without any rhyme or reason. Other things you can do to help:

-Set compatibility mode to Windows XP Service Pack 3.
-Shut down the Aero UI.
-For ATI users in particular, there's a problem with some recent updates to their Radeon video drivers regarding OpenGL. The specific issue is detailed here, and it appears the fix originated in this thread, so yay for Avlis nerds:

Hi guys!
Ressurecting this thread as I just had the same issue.
Fixed it with some elbow grease!

The problem is indeed with the new AMD openGL drivers, atioglxx.dll to be exact, in Catalyst 10.2 and 10.3. If you want to run either of these you need to use the 9.12 version of atioglxx.dll
to do so you can follow this thread [url="http://forums.amd.com/game/messageview.cfm?catid=279&threadid=128067"]here[/url]. Post nine has the info, I'll summarise:

Get a copy of the 9.12 driver, extract the file atioglxx.dl_ using 7-zip (it should be in $_OUTDIR\Packages\Drivers\Display\W76A_INF\B_92022\ or similiar) then use expand in the command prompt as follows:

click start and type cmd in the search bar
go to the directory you extracted atioglxx.dl_ to using cd (for example: cd d:\ati_extract\)
type: "expand atioglxx.dl_ d:\nwn\"

d:\nwn is my nwn install directory.

Rename the expanded atioglxx.dl_ in your nwn directory to atioglxx.dll
All should be happy.

Alternativey you can shoot me a pm and I will give you the file you need to put in your nwn dir.
Or as noted above you can use the 9.12 drivers.

Jay


Aero and Neverwinter Nights

Windows 7 Service Pack 1 will automatically shut down the Aero theme if it detects you're running a program that's not compatible. It flags NWN as such a program, and does exactly that. If you are not running SP1, or Vista, and have stability issues including problems tabbing out or crashes at seemingly random intervals, then you need to manually shut off Aero. I have tested this on several machines so far, and stability under Windows 7 dramatically improved once Aero was turned off. I encourage others to confirm or deny this issue.
Last edited by Aperion on Wed Mar 23, 2011 2:30 am, edited 5 times in total.
User avatar
Aperion
Prince of Bloated Discourse
 
Posts: 176
Joined: Thu Oct 27, 2005 2:03 am
Timezone: PST

Re: Windows 7 + ATI + NWN = :seppukku:

PostAuthor: Manuel the White » Sun Feb 21, 2010 9:55 pm

Bummer buddy. I just got a new 17" Dell. Really liking Windows 7. I'm running NWN as Administrator. I have noticed an increase in crashes from XP. But it's not terrible.
ACTIVE CHARACTERS: Casey Landry, Jessie Morrice
SOMETIMES CHARACTERS: Silinde, Luthias
INACTIVE CHARACTERS: Manuel (the White) Thay't Le'Megen, Zven Reaplenoose, Drashter Volterz
User avatar
Manuel the White
Team Member; Retired with Honors
 
Posts: 7424
Joined: Wed Mar 05, 2003 6:45 pm

Re: Windows 7 + ATI + NWN = :seppukku:

PostAuthor: Darkfire » Sun Feb 21, 2010 10:04 pm

On the short list of things I've already tried:
1. Uninstalling drivers, uninstall NWN, scrub remaining driver profiles, reinstall drivers, reinstall NWN. Nothing.
2. Set Administrative permissions, set WinXP compatability. None of this helps.
3. The Bioware forums. They mention atioglxx in several places, but none of it in this context.
4. ....
5. Still no profit.



Step 4, perhaps you should try ???? instead of .....
CoEMF :devil: :feuer:
WrathOG777: This is a roleplaying game. There is no such thing as winning or losing. Only playing.
Player of Dameon Nepirtas
User avatar
Darkfire
Major DM
Major DM
 
Posts: 13684
Images: 3
Joined: Sat Feb 12, 2005 4:50 pm
Location: Missouri
Timezone: CST (-5 GMT)

Re: Windows 7 + ATI + NWN = :seppukku:

PostAuthor: Aperion » Sun Feb 21, 2010 10:47 pm

Darkfire wrote:
On the short list of things I've already tried:
1. Uninstalling drivers, uninstall NWN, scrub remaining driver profiles, reinstall drivers, reinstall NWN. Nothing.
2. Set Administrative permissions, set WinXP compatability. None of this helps.
3. The Bioware forums. They mention atioglxx in several places, but none of it in this context.
4. ....
5. Still no profit.



Step 4, perhaps you should try ???? instead of .....


You're not going to believe this, but doing ???? actually had an impact.

So, I uninstalled all my ATI drivers. Swept everything out. No more display driver, working in 800x600 resolution at the moment. NWN loads up perfectly.

So the question is now what older driver will work without fucking up NWN? This question, I will answer soonish.

edit: So, the oldest Windows 7 release drivers from ATI work. You know what? I've spent nearly 4 days on this, I'm claiming Mission Accomplished, and moving on right here and now.
User avatar
Aperion
Prince of Bloated Discourse
 
Posts: 176
Joined: Thu Oct 27, 2005 2:03 am
Timezone: PST

Re: Windows 7 + ATI + NWN = :seppukku:

PostAuthor: Darkfire » Sun Feb 21, 2010 11:03 pm

You're welcome!


A friend's computer that I just fixed and installed NWN on... same issue but it was with Windows XP. Looks like ATI is the culprit, not Windows 7. Default drivers that installed with XP for the card (they were proper drivers surprisingly) left the game running very slow, even the startup menu.

Installed the newest drivers for the card and NWN wouldn't even load up. Luckily I had backed his video drivers up onto my computer from 2007 and still had them, so tossed those on there and ta da! Worked great.



Glad you got it all fixed.
CoEMF :devil: :feuer:
WrathOG777: This is a roleplaying game. There is no such thing as winning or losing. Only playing.
Player of Dameon Nepirtas
User avatar
Darkfire
Major DM
Major DM
 
Posts: 13684
Images: 3
Joined: Sat Feb 12, 2005 4:50 pm
Location: Missouri
Timezone: CST (-5 GMT)

Re: Windows 7 + ATI + NWN = :seppukku:

PostAuthor: Aperion » Sun Feb 21, 2010 11:22 pm

Here's what I can determine:

ATI's newest drivers (10.2) come with some new OpenGL stuff, which is what my NWN was getting hung up on. I had to do it properly, but once I got the 10.1 drivers without the new OpenGL material, it all worked again.

So, while I'm not usually one to advocate older drivers, I'll just say back your stuff up before installing the newest ATI drivers that are out there.
User avatar
Aperion
Prince of Bloated Discourse
 
Posts: 176
Joined: Thu Oct 27, 2005 2:03 am
Timezone: PST

Re: Windows 7 + ATI + NWN = :seppukku:

PostAuthor: Li'll Divvil » Mon Feb 22, 2010 3:41 am

I never use the newest gfx drivers for anything. Either Nvidia or ATI.

Had the biggest problems with the (then time) newest Nvidia drivers just after buying an 8800GT (in Jan. 2008 I think), but when I went back to the oldest microsoft certified nvidia drivers that would support my gfx card it worked fine. I waited for a few months, then upgraded to the newest drivers again (newer version than the previous newest drivers of course) and they worked so I guess they fixed whatever was borked.

Rule 1 when upgrading drivers always make sure you have an archive copy of your old ones lying around so you can go back to a version that actually works.
User avatar
Li'll Divvil
Team Member; Retired with Honors
 
Posts: 6493
Joined: Tue Oct 05, 2004 6:57 pm
Location: Dutchie in Germany
Timezone: GMT +1
DM Avatar: Tobin

Re: Windows 7 + ATI + NWN = :seppukku:

PostAuthor: jaythespacehound » Thu Mar 04, 2010 12:35 pm

Hi guys!
Ressurecting this thread as I just had the same issue.
Fixed it with some elbow grease!

The problem is indeed with the new AMD openGL drivers, atioglxx.dll to be exact, in Catalyst 10.2 and 10.3. If you want to run either of these you need to use the 9.12 version of atioglxx.dll
to do so you can follow this thread [url="http://forums.amd.com/game/messageview.cfm?catid=279&threadid=128067"]here[/url]. Post nine has the info, I'll summarise:

Get a copy of the 9.12 driver, extract the file atioglxx.dl_ using 7-zip (it should be in $_OUTDIR\Packages\Drivers\Display\W76A_INF\B_92022\ or similiar) then use expand in the command prompt as follows:

click start and type cmd in the search bar
go to the directory you extracted atioglxx.dl_ to using cd (for example: cd d:\ati_extract\)
type: "expand atioglxx.dl_ d:\nwn\"

d:\nwn is my nwn install directory.

Rename the expanded atioglxx.dl_ in your nwn directory to atioglxx.dll
All should be happy.

Alternativey you can shoot me a pm and I will give you the file you need to put in your nwn dir.
Or as noted above you can use the 9.12 drivers.

Jay
User avatar
jaythespacehound
Apprentice Scholar
 
Posts: 941
Joined: Wed Sep 22, 2004 6:52 am
Location: Hobart Australia (feels like a small island sometimes...hang on it is) GMT+10

Re: Windows 7 + ATI + NWN = :seppukku:

PostAuthor: mhogar » Wed Mar 10, 2010 6:51 pm

big thanks man ... damn AMD
User avatar
mhogar
Power Crafter
 
Posts: 2966
Joined: Sat Feb 19, 2005 6:33 pm
Location: In HEAL storage room
Timezone: GMT +1

Re: Windows 7 + ATI + NWN = :seppukku:

PostAuthor: jaythespacehound » Wed Mar 10, 2010 10:11 pm

No worries, and yes AMD drivers are still not 100% it seems :( But they added a whole bunch of stuff that is awesome so... *sigh*
User avatar
jaythespacehound
Apprentice Scholar
 
Posts: 941
Joined: Wed Sep 22, 2004 6:52 am
Location: Hobart Australia (feels like a small island sometimes...hang on it is) GMT+10

Re: Windows 7 + ATI + NWN = :seppukku:

PostAuthor: Aperion » Wed Mar 10, 2010 11:53 pm

Mixing and matching driver files as described above is a bad idea. It may work perfectly, and have no troubles, or it could really mess up your computer when it makes a call to that atioglxx.dll file that the older version isn't set up to handle.

The simpler solutions is to just use the 10.1 driver, it's the latest that works with NWN still without any issues at all.

Or go with nVidia.
User avatar
Aperion
Prince of Bloated Discourse
 
Posts: 176
Joined: Thu Oct 27, 2005 2:03 am
Timezone: PST

Re: Windows 7 + ATI + NWN = :seppukku:

PostAuthor: EvokedShade » Thu Mar 11, 2010 12:09 am

STRAIGHT FROM RANTS!!!

EvokedShade wrote:Holy shit. Found what I needed here

http://forums.amd.com/game/messageview. ... TMP=Linear

fucking ATI i hate you



BOOM! - Worked for me. I just compressed nwmain.exe with that little program mentioned in the thread. Have't ha a problem since. Stoped the memory leak dead in it's tracks and hasn't messed with my game play or game graphics at all. oh and I turned off Shiney Water in the video advanced menu. ;)

Hope that helps!
Learn, adapt, and repeat.

EvokedShade
Scholar of Fools
 
Posts: 430
Joined: Sun Sep 26, 2004 10:13 am
Location: Spokane, WA

Re: Windows 7 + ATI + NWN = :seppukku:

PostAuthor: EvokedShade » Thu Mar 11, 2010 12:19 am

oh.. and a common sense thing.. don't forget to back up your nwmain.exe :mrgreen:
Learn, adapt, and repeat.

EvokedShade
Scholar of Fools
 
Posts: 430
Joined: Sun Sep 26, 2004 10:13 am
Location: Spokane, WA

Re: Windows 7 + ATI + NWN = :seppukku:

PostAuthor: jaythespacehound » Thu Mar 11, 2010 1:12 am

Aperion wrote:Mixing and matching driver files as described above is a bad idea. It may work perfectly, and have no troubles, or it could really mess up your computer when it makes a call to that atioglxx.dll file that the older version isn't set up to handle.

The simpler solutions is to just use the 10.1 driver, it's the latest that works with NWN still without any issues at all.

Or go with nVidia.


In general, true!
In this case not so big a problem as atioglxx.dll is only being called by nwn (you are not replacing the system atioglxx!) and nwn is known to work well with that version of it. That + nwn isn't likely to update any time soon.

@EvokedShade, Cool, thanks missed that bit! happy with how it's going at the moment but if I have any issues in the future...
User avatar
jaythespacehound
Apprentice Scholar
 
Posts: 941
Joined: Wed Sep 22, 2004 6:52 am
Location: Hobart Australia (feels like a small island sometimes...hang on it is) GMT+10

Re: Windows 7 + ATI + NWN = :seppukku:

PostAuthor: EvokedShade » Thu Mar 11, 2010 2:41 am

jaythespacehound wrote:
Aperion wrote:Mixing and matching driver files as described above is a bad idea. It may work perfectly, and have no troubles, or it could really mess up your computer when it makes a call to that atioglxx.dll file that the older version isn't set up to handle.

The simpler solutions is to just use the 10.1 driver, it's the latest that works with NWN still without any issues at all.

Or go with nVidia.


In general, true!
In this case not so big a problem as atioglxx.dll is only being called by nwn (you are not replacing the system atioglxx!) and nwn is known to work well with that version of it. That + nwn isn't likely to update any time soon.

@EvokedShade, Cool, thanks missed that bit! happy with how it's going at the moment but if I have any issues in the future...


right on.
Learn, adapt, and repeat.

EvokedShade
Scholar of Fools
 
Posts: 430
Joined: Sun Sep 26, 2004 10:13 am
Location: Spokane, WA

Re: Windows 7 + ATI + NWN = :seppukku:

PostAuthor: Krator » Thu Sep 16, 2010 10:08 pm

jaythespacehound wrote:Hi guys!
Ressurecting this thread as I just had the same issue.
Fixed it with some elbow grease!

The problem is indeed with the new AMD openGL drivers, atioglxx.dll to be exact, in Catalyst 10.2 and 10.3. If you want to run either of these you need to use the 9.12 version of atioglxx.dll
to do so you can follow this thread [url="http://forums.amd.com/game/messageview.cfm?catid=279&threadid=128067"]here[/url]. Post nine has the info, I'll summarise:

Get a copy of the 9.12 driver, extract the file atioglxx.dl_ using 7-zip (it should be in $_OUTDIR\Packages\Drivers\Display\W76A_INF\B_92022\ or similiar) then use expand in the command prompt as follows:

click start and type cmd in the search bar
go to the directory you extracted atioglxx.dl_ to using cd (for example: cd d:\ati_extract\)
type: "expand atioglxx.dl_ d:\nwn\"

d:\nwn is my nwn install directory.

Rename the expanded atioglxx.dl_ in your nwn directory to atioglxx.dll
All should be happy.

Alternativey you can shoot me a pm and I will give you the file you need to put in your nwn dir.
Or as noted above you can use the 9.12 drivers.

Jay


Thanks for this guys.

Googled the problem, this thread was hit #1 :)
Playing as: Sir Douglas Hope of Gorethar, old school paladin | Krator Blackfist, gold mage | Warren, half nymph barbarian
User avatar
Krator
Elder Sage
 
Posts: 4947
Joined: Thu Jun 10, 2004 6:44 pm
Location: Amsterdam
Timezone: GMT

Re: ATI + NWN = :seppukku:

PostAuthor: Aperion » Thu Sep 16, 2010 10:54 pm

o hey this thread
User avatar
Aperion
Prince of Bloated Discourse
 
Posts: 176
Joined: Thu Oct 27, 2005 2:03 am
Timezone: PST

Re: Fixing issues with Vista/7 and NWN

PostAuthor: Aperion » Wed Mar 23, 2011 2:23 am

Bumping this thread. I've turned the OP into more of a general 'if things go wrong, here's what you do first' post. I've tried to make it as simple as possible and included some information beyond the problems of ATI, which is originally what this thread was about. It seems that every so often that someone needs help with getting NWN to run properly on newer operating systems or hardware.
User avatar
Aperion
Prince of Bloated Discourse
 
Posts: 176
Joined: Thu Oct 27, 2005 2:03 am
Timezone: PST

Re: Fixing issues with Vista/7 and NWN

PostAuthor: mhogar » Wed May 02, 2012 5:12 pm

*tests this old solution for catalyst 12.4 with the atioglxx.dll from catalyst 12.1*

IT SEEMS TO WORK
User avatar
mhogar
Power Crafter
 
Posts: 2966
Joined: Sat Feb 19, 2005 6:33 pm
Location: In HEAL storage room
Timezone: GMT +1

Re: Fixing issues with Vista/7 and NWN

PostAuthor: Vanar Alhaldren » Fri Jun 15, 2012 1:08 am

This thread is super helpful! Seriously. Must have been the new graphics card I got a while back (just a newer version of the last radeon I had so not sure why this one was so unhappy, but whatever) but this is what has gotten things up and running again. Thanks!

Vanar Alhaldren
Bronze Contributor
 
Posts: 1111
Images: 2
Joined: Mon Nov 21, 2005 5:09 pm
Timezone: CST (GMT -6)

Re: Fixing issues with Vista/7 and NWN

PostAuthor: HeroOfTime49 » Sat Mar 09, 2013 6:48 pm

I jut got a Windows 8 computer. Do you guys think this process will work for it too? I just wanted to ask before I went through the trouble. I am not too computer savvy.

HeroOfTime49
Newbie
 
Posts: 4
Joined: Sat Aug 04, 2012 1:02 am

Re: Fixing issues with Vista/7 and NWN

PostAuthor: Levis Pie » Wed Jun 19, 2013 2:52 am

So I've tried running as Admin, compatability xp service pack 2 & 3, graphics lower than my standards, still choppy as a midsummer squall matey! Don't suppose it would have anything to do with the fact I don't have a vid card? Would she run right using XP even w/o a card? Not exactly the most 'puter savvy but I'll re-read more in depth in a couple days when I have 'net access again and a little more time.
Member of the Plethora Fan Club!
nwmblondy wrote:*Kisses Levis Pie*
User avatar
Levis Pie
Sage
 
Posts: 2049
Joined: Wed Jun 01, 2005 11:12 pm
Location: SEMO
Timezone: CST

Re: Fixing issues with Vista/7 and NWN

PostAuthor: tindertwiggy » Wed Jun 19, 2013 11:28 am

Levis Pie wrote:So I've tried running as Admin, compatability xp service pack 2 & 3, graphics lower than my standards, still choppy as a midsummer squall matey! Don't suppose it would have anything to do with the fact I don't have a vid card? Would she run right using XP even w/o a card? Not exactly the most 'puter savvy but I'll re-read more in depth in a couple days when I have 'net access again and a little more time.


What video card do you have? You have to have something in there if there is a monitor attached to your computer.
Happiness is baked with one part bat guano, one part sulfur.

tindertwiggy
Legacy DM
Legacy DM
 
Posts: 6682
Images: 1
Joined: Tue Jul 16, 2002 12:20 am
Location: Nippon

Re: Fixing issues with Vista/7 and NWN

PostAuthor: Gumble Tinkertumble » Wed Jun 19, 2013 12:31 pm

On board GPU?
User avatar
Gumble Tinkertumble
Sage
 
Posts: 1706
Images: 1
Joined: Thu Jun 23, 2005 1:57 pm
Location: UK
Timezone: GMT

Re: Fixing issues with Vista/7 and NWN

PostAuthor: Levis Pie » Thu Jun 20, 2013 6:25 pm

aye, onboard i'm assuming.
Member of the Plethora Fan Club!
nwmblondy wrote:*Kisses Levis Pie*
User avatar
Levis Pie
Sage
 
Posts: 2049
Joined: Wed Jun 01, 2005 11:12 pm
Location: SEMO
Timezone: CST

Next

Return to NWN General Discussion

Who is online

Registered users: Bing [Bot], Google [Bot]