Server Totals
Mikona - (1)
Le'Or - (0)
Ferrell - (0)
Elysia - (0)
M'Chek - (0)
Deglos - (0)
Wilderness - (0)
Visimontium - (0)
Underdark - (0)
Total players: 1
Gallery

Links Menu

NWN windowed & CTD

Moderators: Nighthawk4, Dungeon Masters

NWN windowed & CTD

PostAuthor: Game-Extremist » Fri Nov 11, 2005 1:54 am

For the late week I have been having a problem with my NWN program, I tend to switch back and forth between NWN and my desktop for a number of reasons, normally while DM'ing.

Problem is when I do this now ( for the last week or so) I crash as soon as I hit the little windows key to get back to the desktop....Its annoying and cramping my style.

The only change I have made recently (that I remember) was a video driver (ATI catalyst) update but that was carried out after the problem started.

Any ideas?

Please don't tell me to reinstall NWN. :(

Game-Extremist
Team Member; Retired with Honors
 
Posts: 1606
Joined: Sun Aug 15, 2004 12:06 am
Location: Norseman, GMT + 8

PostAuthor: Pathos Street » Fri Nov 11, 2005 2:18 am

in nwn.ini

FullScreen=0
AllowWindowedMode=1

Set your NWN resolution lower than your desktop resolution. I've got my desktop at 1280 x 1084, and have dropped NWN all the way down to 800 x 600.

That way you will be able to just click on the desktop or whatever other programs you are running to shift screen focus away from NWN. The downside is you can no longer rotate the screen by mousing over the edge.

Clicking on the little windows key shouldn't be a problem, cause you won't need to do it. I've done this for lectures and meetings numerous times and never had a problem. (of course I've never tried this with the DM client, so YMMV)

:D
User avatar
Pathos Street
King of Avlis Charades
 
Posts: 4804
Joined: Mon Oct 11, 2004 11:33 pm
Location: Hawkeye State
Timezone: CDT (GMT -5)

PostAuthor: Hert Snyder » Fri Nov 11, 2005 2:44 am

Pathos Street wrote:in nwn.ini

FullScreen=0
AllowWindowedMode=1

Set your NWN resolution lower than your desktop resolution. I've got my desktop at 1280 x 1084, and have dropped NWN all the way down to 800 x 600.

That way you will be able to just click on the desktop or whatever other programs you are running to shift screen focus away from NWN. The downside is you can no longer rotate the screen by mousing over the edge.

Clicking on the little windows key shouldn't be a problem, cause you won't need to do it. I've done this for lectures and meetings numerous times and never had a problem. (of course I've never tried this with the DM client, so YMMV)

:D


Actually:

After adding those lines, you can use Alt+Enter to switch effortlessly between Windowed mode and Fullscreen.

-spool32

Hert Snyder
Sage
 
Posts: 2082
Joined: Thu Dec 16, 2004 2:09 pm

PostAuthor: Alphonse » Fri Nov 11, 2005 8:36 am

I have this problem fairly frequently too. It usually occurs if i alt-tab a lot, when i'm looking for information on the forums or something.

Its definately a graphics card issue, because my graphics card has a software reset if it crashes so it can recover from it and give me a message to stop being an ass.

I'm yet to find out exactly why it keeps crashing though
Irreverence Awards 05 :most Ineffectual PC, honourable mention for most likely to give/recieve Spite

Islands of the Lost Head DM
User avatar
Alphonse
Master Sage
 
Posts: 5306
Joined: Wed Nov 03, 2004 8:26 am
Location: GMT

PostAuthor: Anastase » Fri Nov 11, 2005 11:14 am

I had this problem as well after I had recently reformated my hardrive and reinstalled NWN. I believe the problem was caused because I imported my previous nwn.ini file, and something must have been off with the new reinstall.

I tried to fix it by updating my ATI driver. That didn't help. So I uninstalled and reinstalled NWN again (to restore the nwn.ini file to the original version) and that stopped the crashes. I do have to alt-tab to choose NWN sometimes still when I use my window key to get out and come back, because it will let me see inside the game but it won't let me do anything (nothing is clickable and keyboard doesn't work).

I know reinstalling NWN is a painful solution. I don't know if we were having the same problems, but it's possible something is corrupted in your files and causing this. That was the advice I was given and it worked for me. I didn't want to go to a lower screen resolution (to use windowed mode) so reinstalling was necessary. Hope you find the problem and get it fixed soon. I know how frustrating it was to not be able to get out of NWN without crashing completely.
User avatar
Anastase
Squire of Babble
 
Posts: 35
Joined: Sun Nov 06, 2005 4:07 am
Location: Texas

PostAuthor: Talwin Hawkins » Fri Nov 11, 2005 11:56 am

You no doubt are eithe running an ATI All in wonder GFX card or a Radeo 9600. The new drivers for this are incompatible with NWN. Thanks to Krator i dowloaded some drives called Omega drivers.(not sure about the link)

Search for these. These are compatible with NWN and IMO better tan the orginanal ones. My graphics appear smoother and brighter.
User avatar
Talwin Hawkins
Team Member; Retired with Honors
 
Posts: 3981
Joined: Fri Aug 27, 2004 7:56 pm
Location: London - England GMT
Timezone: GMT+1

PostAuthor: Anacor » Fri Nov 11, 2005 4:46 pm

Pathos Street wrote:in nwn.ini

FullScreen=0
AllowWindowedMode=1

Set your NWN resolution lower than your desktop resolution. I've got my desktop at 1280 x 1084, and have dropped NWN all the way down to 800 x 600.

:D


I use windowed mode all the time, and my desktop and NWN resolution are both at 1280x1024, and when I set it to windowed mode it becomes a much smaller screen. So, I don't think the resolution of NWN matters.
User avatar
Anacor
Squire of Babble
 
Posts: 25
Joined: Sun Jan 16, 2005 8:52 pm

PostAuthor: Game-Extremist » Sat Nov 12, 2005 7:52 am

Thanks for all the advice, I tried the .ini file method without success as it was the quickest. I feel that Talwin is on to something though as I do have one of the 9600 Radeon series.

I've also heard that the Omega drivers were the goods from another website, that was in reference to problems between ATI drivers and Civ 4.

Thanks agan! :)

Game-Extremist
Team Member; Retired with Honors
 
Posts: 1606
Joined: Sun Aug 15, 2004 12:06 am
Location: Norseman, GMT + 8

PostAuthor: Talwin Hawkins » Sat Nov 12, 2005 10:46 am

I know im right. I have a Radeon 9600XT with the same problem. I am now a happy elf..err..man.
User avatar
Talwin Hawkins
Team Member; Retired with Honors
 
Posts: 3981
Joined: Fri Aug 27, 2004 7:56 pm
Location: London - England GMT
Timezone: GMT+1

PostAuthor: Moredo » Sat Nov 12, 2005 10:53 am

Here are the omega drivers:

http://omegadrivers.net/ati/win2k_xp.php

I changed to these, but I didn't see any improvement on the preformance of my ATI Radeon 9700 Pro card. So I switched back to the latest updated (original) ATI drivers.
Always consider alignment as a tool, not a straitjacket that restricts the character.
— AD&D, 2nd Edition Player's Handbook
User avatar
Moredo
CCC
CCC
 
Posts: 7409
Joined: Mon May 26, 2003 3:47 pm
Location: Norway (GMT +2)
Timezone: +2

PostAuthor: Zebranky » Sat Nov 12, 2005 2:33 pm

I have a Radeon 9600Pro. Using old Catalysts (sorry, don't remember the version, maybe 5.6?) with no problems. Tried the next version for a couple days, simply couldn't play NWN until I reverted. Take this, ATI. :finger:
Code: Select all
<Zebranky> (Also, that would piss SO many people off. ;)
<Nob> That's why it's such a great idea, Zeb.
User avatar
Zebranky
Scholar of Fools
 
Posts: 338
Joined: Sun Jul 04, 2004 5:40 am
Location: MA, USA (GMT -5)

PostAuthor: Croton » Sat Nov 12, 2005 2:43 pm

on this same general topic, I get this annoying double mouse in NWN if I switch between desk top and NWN.

Any hints?

Croton
Team Member; Retired with Honors
 
Posts: 5950
Joined: Mon Jun 09, 2003 4:29 pm
Location: (-4 GMT - Summer)

PostAuthor: Wyrmwing » Sat Nov 12, 2005 6:42 pm

I gave up trying to get NWN working on this computer.. the Radeon 9600 keeps locking up within a minute or two no matter what I've tried :(

*wishes he was back at his own comp*

As for solutions.. get a GeForce? ;)
Sadako Sasaki wrote:I will write peace on your wings, and you will fly all over the world.

Wyrmwing
Team Member; Retired with Honors
 
Posts: 5830
Joined: Mon Aug 25, 2003 6:41 pm
Location: Croissant Country

PostAuthor: Anacor » Sat Nov 12, 2005 9:23 pm

I love my Geforce 7800 GTX. 8)
User avatar
Anacor
Squire of Babble
 
Posts: 25
Joined: Sun Jan 16, 2005 8:52 pm

PostAuthor: Anastase » Sun Nov 13, 2005 11:53 am

Hmm, I tried downloading the Omega drivers (since I've also read elsewhere that the ATI aren't as compatable) and I actually noticed a decrease in my video quality. Instead of smooth color tones everything is seen in "patches". Do I need to do something with the settings to fix this? I'm not very good when it comes to stuff like this so I'll have someone else look at it from my side too ~giggles~
User avatar
Anastase
Squire of Babble
 
Posts: 35
Joined: Sun Nov 06, 2005 4:07 am
Location: Texas

PostAuthor: Talwin Hawkins » Sun Nov 13, 2005 12:08 pm

Mine work really well. You need to uninstal the ati drivers and the catalyst thingy ma bob. this resets the computer to the standard 16colour crap.

THEN install Omega drivers and its good for me.

And they are compatible with Nwn.
User avatar
Talwin Hawkins
Team Member; Retired with Honors
 
Posts: 3981
Joined: Fri Aug 27, 2004 7:56 pm
Location: London - England GMT
Timezone: GMT+1

PostAuthor: Anastase » Mon Nov 14, 2005 1:27 pm

Hmm. Well I tried uninstalling anything ATI connected, then I installed the Omega drivers from the link above. I don't know if I'm doing something wrong, but it still looked really patchy and I saw no increased performance. I'm still having to alt-tab and rechoose NWN if I window out to my desktop also (not sure if this is a normal thing, I wish it would just automatically choose NWN so I wouldn't have to bother with that).

I went ahead and reinstalled ATI and the patchiness is gone. Anyone have any idea what I'm doing wrong with the Omega?
User avatar
Anastase
Squire of Babble
 
Posts: 35
Joined: Sun Nov 06, 2005 4:07 am
Location: Texas

PostAuthor: 763heylynn » Tue Nov 15, 2005 11:52 pm

I did the .ini settings but can't stand not being able to rotate the screen so I enlarge the window anyway.

If I alt-tab to desktop I only have so much time. If I wait too long (40-50 seconds) before alt-tabbing back then I get a screen of all red or blue or black for NWN but I can still hear stuff. I have to crash the game and relog on.

I was thinking about getting a video card to support 2 monitors so that I could much more easily mutlitask (for other stuff too, not just the game). I am unsure whether or not this would cause a lock up anyway for focusing on a different screen.

Anyone?
It's fun to do the impossible!
Another adventure? I just wanted to craft!
It's not my world, it's not my rules, I don't live here like they do. I just love to visit!!! *claps* GO DMs!!

763heylynn
Knight of Useless Drivel
 
Posts: 75
Joined: Wed Aug 17, 2005 2:23 am
Location: GMT -5..DST GMT -6 ?I think--US CentralTimeZone

PostAuthor: pincushionman » Wed Nov 16, 2005 12:33 am

I alt-tab rather than Windows key.

BUT

I have to have another application active (that is, not minimized), even if it's just an open Windows Explorer window, I have to alt-tab to that or it just kicks me back into NWN and jacks up my controls. Not usually an issue, since the only reason I alt-tab out is to use another app anyway.

PLUS

I can't alt-tab back into NWN. If I do, I lose all controls. The mouse moves on the screen, but neither it nor the keyboard actually do anything. I need to actually click on NWN in the taskbar to get back in properly.

I am also using the latest ATI drivers.

Those things help any?
Suuhoroh . Shaahesk fighter . Journeyman armorwright, Avlis Arms and Armor Association . Corporal, M'Chek Army Blackhawk Company
Cookie (Amakiir) . Kobold chef extrordinaire - he thinks

lizard shields viewtopic.php?t=53138
timezone calc http://www.worldtimeserver.com/time_converter.aspx
AAAA recruitment viewtopic.php?t=62035
User avatar
pincushionman
Apprentice Scholar
 
Posts: 979
Joined: Thu Mar 17, 2005 3:59 pm
Location: Big, flat Kansas (GMT-6)

PostAuthor: terror2001 » Fri Nov 18, 2005 10:34 pm

slave_of_emotions wrote:or just use this tool http://nwvault.ign.com/View.php?view=ot ... ail&id=259


This program is actually very easy to use to modify these settings as well as several other settings.
User avatar
terror2001
Apprentice Scholar
 
Posts: 922
Joined: Wed Jun 22, 2005 1:48 am
Location: GMT -7(-6)

PostAuthor: Defender » Fri Nov 18, 2005 11:38 pm

Let me enlighten everyone about this whole ATI issue.

I have a 9700 and I will clue everyone in on something.

ATI SUCKS!!!

Pretty much as simple as that.

Unless you want to say that ATI just sucks for NWN's, which it greatly does.

The problem isnt the ATI drivers or the OMEGA drivers. The card itself sucks major monkey ass!

Anytime I walk up on people or in an area that has even close to a few things going on, my framerate freezes for a moment and takes a crap all over the floor, and then decides to keep on moving.

Anytime I go to a certain arena server where there are lots of people playing and casting and such, and I turn a way that my ATI PoS card doesnt like, FREEZE-UP!

ATI and NWN's completely sucks ass together. They are obviously not working together as team-mates. I think they both need fired.

My 2 cents,
Michael K

Image
User avatar
Defender
Apprentice Scholar
 
Posts: 532
Joined: Mon Jun 07, 2004 4:20 am
Location: GMT -6

PostAuthor: Game-Extremist » Sat Nov 19, 2005 3:43 pm

YARR!

Omega drivers worked!

Now I can jump between my desktop and NWN at will!

Thanks all for your help!

Game-Extremist
Team Member; Retired with Honors
 
Posts: 1606
Joined: Sun Aug 15, 2004 12:06 am
Location: Norseman, GMT + 8

PostAuthor: Arnimane » Sat Nov 19, 2005 3:46 pm

I was having loads of instability problems until the 5.11 drivers released. Might also look those up.
Lead me not unto temptation...I know the way.

Arnimane
Scholar
 
Posts: 1495
Joined: Thu Mar 18, 2004 7:03 am

PostAuthor: terror2001 » Sun Nov 20, 2005 5:18 pm

763heylynn wrote:I did the .ini settings but can't stand not being able to rotate the screen so I enlarge the window anyway.

If I alt-tab to desktop I only have so much time. If I wait too long (40-50 seconds) before alt-tabbing back then I get a screen of all red or blue or black for NWN but I can still hear stuff. I have to crash the game and relog on.

I was thinking about getting a video card to support 2 monitors so that I could much more easily mutlitask (for other stuff too, not just the game). I am unsure whether or not this would cause a lock up anyway for focusing on a different screen.

Anyone?


One thing to try is a different refresh rate. So in Windows if you are running like 85Hz refresh rate, try a different one like 75Hz. Then set your game refresh rate to the same as Windows.
I've had screwy things like this work for me in the past.

Terror2001
User avatar
terror2001
Apprentice Scholar
 
Posts: 922
Joined: Wed Jun 22, 2005 1:48 am
Location: GMT -7(-6)


Return to NWN General Discussion

Who is online

Registered users: Bing [Bot], ShadowViper