Server Totals
Wilderness - (3)
Ferrell - (1)
Elysia - (0)
Le'Or - (0)
M'Chek - (0)
Deglos - (0)
Visimontium - (0)
Underdark - (0)
Mikona - (0)
Total players: 4
Gallery

Links Menu

PC's not being returned to their logout point after reboot

Moderators: Nighthawk4, Dungeon Masters

PC's not being returned to their logout point after reboot

PostAuthor: terror2001 » Wed Jun 22, 2005 2:00 am

I'm one of the developers on the World of Greyhawk server that will be coming out soon to link with Avlis, and we're having the problem of PC's not being restored to their palces where they logged out after a restart of the server; PC's show up at the start area.
I'd post this on the Copap website, but it seems to be down so thought I'd ask here how to get the server to restore locations. The only errors I see are in the logs.0 folder in the nwnx.txt file it lists lots of "Library HASHSET!XXXX does not exist" where XXXX = CREATE, GETSIZE, GETFIRSTKEY, etc.
The other log files do not show any error and the link to the database shows successful.
Wondering if I'm missing some scripts in the avlis base mod.

Anyone have any ideas?
User avatar
terror2001
Apprentice Scholar
 
Posts: 923
Joined: Wed Jun 22, 2005 1:48 am
Location: GMT -7(-6)

PostAuthor: Psyco » Wed Jun 22, 2005 2:27 am

first thing to check is that their location is being saved to teh databse when they log out. If not, then thats where your problem is, if so then teh second thing to check is does your module onEnter script (i think) check for that location and jump them to it.
Player Housing info - This answers most questions people have. Read this before asking.
User avatar
Psyco
Elder Sage
 
Posts: 3297
Joined: Mon Jun 30, 2003 10:05 pm
Location: New Zealand (NZDT, +12 GMT)

PostAuthor: terror2001 » Wed Jun 22, 2005 3:51 am

I have the "avlis_onenter" and "avlis_onexit" scripts in the module events.
When looking at the database the "laslocation" table shows my PC's, but has 0's for X,Y,Z,Facing, and a blank entry for Area. I know it's writing to the table because the player, character, server, and timestamp are written correctly.
I didn't see anything relevant in the player housing link.
User avatar
terror2001
Apprentice Scholar
 
Posts: 923
Joined: Wed Jun 22, 2005 1:48 am
Location: GMT -7(-6)

PostAuthor: Jonezie » Wed Jun 22, 2005 3:53 am

Player Housing is in his sig. :wink:

Have you got 'avlisarea_onenter' and 'avlisarea_onexit' in your areas' OnEnter and OnExit events?

EDIT - Oh, and you also should have 'loctrck_strtarea' in the start tent's OnEnter.
User avatar
Jonezie
Team Member; Retired with Honors
 
Posts: 3906
Joined: Wed Jun 09, 2004 7:05 am
Location: Melbourne (GMT +10)

PostAuthor: terror2001 » Wed Jun 22, 2005 4:12 am

Excellent. I was missing those scripts on the areas.

Thanks guys for your help.
User avatar
terror2001
Apprentice Scholar
 
Posts: 923
Joined: Wed Jun 22, 2005 1:48 am
Location: GMT -7(-6)


Return to NWN Scripting

Who is online

Registered users: Bing [Bot], Google [Bot], Tel