Page 1 of 1

Mouse problem - Win 10

PostPosted: Sat Oct 17, 2015 12:56 pm
Author: badjabadjabadja
Hi guys,

I was messing about with my brother's ASUS X205TA - running Windows 10 on an intel atom CPU, 2GB ram & while we installed the NWN demo on it ok.. set compatibility to XP sp3 & run as admin, but on the load screen we were unable to click 'new game' (or any other option).

A work-around seemed to be: alt tab (out & in) -(cursor appears but won't click anything) position cursor onto desired button - alt tab again and this time the mouse cursor disappears, but then you can actively click with the mouse (despite having no visible cursor!)

Once we started the demo it was reporting 62fps!

Can't find any fix for the mouse weirdness tho (it's either visible but non-functional, or invisible but functional!)

Any ideas anyone?

Re: Mouse problem - Win 10

PostPosted: Sat Oct 17, 2015 9:29 pm
Author: tindertwiggy
Is this a mouse or touchpad? If a mouse, what happens if you connect or disconnect/reconnect it after starting nwn?

Re: Mouse problem - Win 10

PostPosted: Sat Oct 17, 2015 9:54 pm
Author: Tel
I have had some issues with Windows 8 where it loads and if I wasn't focused on NWN I have to click on, off and then back but works fine after that (running windowed mode)

Re: Mouse problem - Win 10

PostPosted: Sun Oct 18, 2015 12:42 am
Author: Gorgon
That glitch is around even in XP. If you play in a window and close another app (or many other ways of it switching back to NWN on its own), then you can't click anything on the load screen menu. It is easy enough to click outside and back again in windowed mode, but if you are getting it when full screen, then like you said, alt-tab out and back (or switch to windowed mode, if you have it enabled) and it should do the trick.

For some reason the menu is slow to notice the mouse focus is back, so it needs a second nudge. That is me saying I have no clue why it happens, but it isn't a big deal for me to do a few clicks. If it happened IG often, then it might be different.

Re: Mouse problem - Win 10

PostPosted: Sun Oct 18, 2015 12:51 am
Author: Gorgon
Random guess that might help with the cursor disappearing is to change your "Enable HardwareMouse=0" to "Enable HardwareMouse=1" (or the reverse if it already is set to 1) under the [Video Options] section of nwn.ini in the game folder.

*edit* You really want it enabled (=1) if you can play with it.

You can try Googling the problem for a more informed reply. Got a movie to watch, or I would. :P

Re: Mouse problem - Win 10

PostPosted: Sun Oct 18, 2015 10:19 am
Author: badjabadjabadja
Thanks guys, this is a tiny 11.6" screen net book thingy, and as the one my brother has cost only £120 I was thinking to get one to use as a mobile device for when I'm travelling away from home. This does have just a 32GB SSD hard-wired to the mobo, so I guess a full install may have to rely on using an SD-micro card for additional storage space.

It has a trackpad - we've also tried with a usb mouse. "Enable HardwareMouse=1" means you can either have a visible but non-active cursor, but alt-tab will turn it invisible but active! Re-plugging the mouse did nothing. Did not have much success googling it either, hence posting here.

Changing the nwn.ini settings to: "Enable HardwareMouse=0" seems to have fixed the initial glitch.

Went back to Enable HardwareMouse=1, and alt-mouse click seems to fix as well.. tho there is a time delay. Tried various other keys... seems (after pressing alt-tab twice to get visible but non clicking cursor) just pressing the 'alt' key then enables mouse clicking !

Strange!