Page 1 of 1

NWN and win 7

PostPosted: Sat Dec 08, 2012 5:47 pm
Author: Korennya
Okay, finally got win 7 installed on too new hardware (12 hours to install :(, just one big headache). Installed nwn today, set it up to run as administrator and in win xp sp3 mode. Game boots up fine and I get to the screen to pick mulitplayer... wait and wait for MS response (have to search for fixing that in win 7). Then the gamespy window loads up and I get the old pause like it did in xp as it loads all the servers into the window, but there is nothing there. Select every different type of server on the side and there are zero servers loading into the window.

So I alt tabed back to the desktop and there was a screen there for firewall permissions waiting. I clicked it to allow. Restarted NWN and still the same thing. I can't get any of the servers to show so I can select one to log into.

Ideas?

I also went back into the win firewall and checked it. NWN is there and set to pass through local network. I also cllicked it for public as well but that had no effect either.

Re: NWN and win 7

PostPosted: Sat Dec 08, 2012 5:58 pm
Author: Seka

Re: NWN and win 7

PostPosted: Sat Dec 08, 2012 6:04 pm
Author: Korennya
opps. Thanks. I thought it was somethings screwed up with the win 7 install being as this is my first time using win 7 and NWN. Used the direct connect and all is well, got into elysia just fine. Glad it wasn't me after all. Now if I could just get it to load avlis website up without huge connecting to www.avlis.org delays....

Re: NWN and win 7

PostPosted: Sun Dec 09, 2012 2:51 pm
Author: Gumble Tinkertumble
Hmmm, you could try adding an entry to your hosts file to speed up resolving the website address. Assuming it has a static IP I believe it is 74.208.72.81
So you could add the following to the end of the file.
74.208.72.81 www.avlis.org

Naturally, if it isn't a static IP or if ever gets changed, you would need to update the hosts file again.

Re: NWN and win 7

PostPosted: Sun Dec 09, 2012 3:02 pm
Author: Korennya
Problem is that it's not just avlis' site. Everything is going slow. Painfully, takes about 10 secs to resolve a DNS. Bottom of the windows just shows looking up www.yadayada.com. If the site has ads, it takes even longer because it lags looking up each domain that each ad is coming from. Once it completes the look up the page pops right up.

Does it both in IE and firefox. I tried yesterday resetting my cable modem and router, which did speed things up some. I then edited the iv6 and iv4 protocols to use google's open dns servers, which also sped things up some. It's just not as quick as it should be. Speedtest.net shows a solid 14Mbps which is the same as it's been for the past 4 years. Using a wired ethernet connection.

Seems like any page i've visited and has been cached pops up near instant. New ones take a while just sitting at blank white screen, then everything just pops up. In IE, at the tab, the little circle spins grey and backwards for a long time, saying connecting to www.... then it finally goes clockwise and green for a split second and the page is there.

Re: NWN and win 7

PostPosted: Sun Dec 09, 2012 3:03 pm
Author: Korennya
Posting that last post. Spun backwards grey for 4 seconds saying connecting... then it was just here.. didn't even get a chance to spin to the right and go green.

You tube video's do the same thing. A video will sit there black with the dots twirling for a good 20-30 secs, once video starts you can see the content bar on the bottom fly to the right as it gets data.

Re: NWN and win 7

PostPosted: Sun Dec 09, 2012 3:24 pm
Author: Gumble Tinkertumble
Have you got any funky toolbars installed that may be doing something silly? The Ask toolbar is a known culprit for instance.

Re: NWN and win 7

PostPosted: Sun Dec 09, 2012 4:13 pm
Author: Korennya
No toolbars.. I always refuse those. Only add-on firefox is using is an ad-blocker, which helped speed things up a bit.

Re: NWN and win 7

PostPosted: Wed Dec 12, 2012 9:05 pm
Author: terror2001
You might be pointing to a bad DNS server as primary so it sits and waits for it to time out before trying the secondary. Try swapping the DNS entries or pointing to more reliable DNS servers.

Re: NWN and win 7

PostPosted: Thu Dec 13, 2012 12:01 am
Author: Korennya
I changed both iv4 and iv6 protocols to use google's open dns service. Had minimal effect. Is there a better service to use?

Re: NWN and win 7

PostPosted: Thu Dec 13, 2012 1:03 am
Author: Sathsarrion
Comodo security runs some public DNS servers at 8.26.56.26 and 8.20.247.20 . They can be a little overzealous about blocking sites they think are shady, but if the problem you are describing still occurs there then I think you can rule out the DNS server as a cause.

Re: NWN and win 7

PostPosted: Thu Dec 13, 2012 1:10 am
Author: Korennya
I'll give them a try when I get home, thanks