Page 1 of 2

Today hates me I swear

PostPosted: Tue Mar 20, 2012 9:47 am
Author: LadyAwesome
My game wont open, it pretends its loading then comes up with - neverwinter nights has stopped working, a problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available and rage quits on me.

Im on Vista

Re: Today hates me I swear

PostPosted: Tue Mar 20, 2012 9:58 am
Author: Plethora
Please help her, she's a Kiwi

Re: Today hates me I swear

PostPosted: Tue Mar 20, 2012 10:04 am
Author: LadyAwesome
Why thanks for that intro lady Plethness.

Re: Today hates me I swear

PostPosted: Tue Mar 20, 2012 10:11 am
Author: Plethora
I do what I can, lovely Lady

Re: Today hates me I swear

PostPosted: Tue Mar 20, 2012 10:27 am
Author: GunnJ
have you tried going into the game's folder and running nwmain.exe? Perhaps the problem is with the loader and not the game itself?

Re: Today hates me I swear

PostPosted: Tue Mar 20, 2012 11:02 am
Author: ShadowViper
reboot your pc/notebook.

Re: Today hates me I swear

PostPosted: Tue Mar 20, 2012 11:25 am
Author: Ashan
GunnJ wrote:have you tried going into the game's folder and running nwmain.exe? Perhaps the problem is with the loader and not the game itself?

I had a similar problem and launching the Nwmain.exe file sorted it.

Re: Today hates me I swear

PostPosted: Tue Mar 20, 2012 11:47 am
Author: Plethora
Ashan wrote:
GunnJ wrote:have you tried going into the game's folder and running nwmain.exe? Perhaps the problem is with the loader and not the game itself?

I had a similar problem and launching the Nwmain.exe file sorted it.

actually so did I with vista

Re: Today hates me I swear

PostPosted: Tue Mar 20, 2012 1:28 pm
Author: Grunt
Plethora wrote:Please help her, she's a Kiwi on Vista


Fixed that for you.

Re: Today hates me I swear

PostPosted: Tue Mar 20, 2012 7:39 pm
Author: LadyAwesome
I could never play on the other game thingy I had to play on the main exe the whole time

LOL grunt. I love you people

Also...... that is not the problem it is still doing the same thing

Re: Today hates me I swear

PostPosted: Tue Mar 20, 2012 8:35 pm
Author: Speedracer
Try right clicking on your NWN icon and selecting run as administrator. My NWN won't run without doing that. I R on Vista too. I feel your pain!!

Re: Today hates me I swear

PostPosted: Tue Mar 20, 2012 9:04 pm
Author: Nighthawk4
Vista's UAC is much more restrictive than on Windows7, so that might be the problem.

Good luck :wink:

Re: Today hates me I swear

PostPosted: Tue Mar 20, 2012 11:57 pm
Author: LadyAwesome
Nope that does not work either :(

Re: Today hates me I swear

PostPosted: Wed Mar 21, 2012 12:12 am
Author: Ashan
If all else fails a reinstall of the game might fix it(remember to make a copy of your hak folder first)

Re: Today hates me I swear

PostPosted: Wed Mar 21, 2012 2:48 am
Author: LadyAwesome
Re-installing didnt work either.

UAC was never on in the first place, I have taken off the movie bits, movie=1, reinstalled made sure the uac wasnt on, and some other stuff I cant remember..... Sad face


I can't fix this so I guess I shall see you all someday.

Re: Today hates me I swear

PostPosted: Wed Mar 21, 2012 3:29 pm
Author: Shadow Monkey
Did you modify your.ini files?


In nwnplayer.ini put/edit line: Client CPU Affinity=-2

In nwnconfig.ini put/edit line: NumCPUs=1


Also try installing it in a different directory... worked for me (but I'm on W7).

Re: Today hates me I swear

PostPosted: Wed Mar 21, 2012 6:04 pm
Author: Nighthawk4
Just a thought - it only takes about 10 minutes to install Ubuntu and the NWN Client works fine on that :wink:

:flucht:

Re: Today hates me I swear

PostPosted: Thu Mar 22, 2012 8:17 am
Author: LadyAwesome
What is Ubuntu?

And what does changing those .ini files actually do?

Because I cant even get to the movie part of the screen - it is instant crash.
Sarm seems to think its my drivers causing the problem and I can get the old verson.

Re: Today hates me I swear

PostPosted: Thu Mar 22, 2012 1:54 pm
Author: Grunt
LadyAwesome wrote:What is Ubuntu?

And what does changing those .ini files actually do?

Because I cant even get to the movie part of the screen - it is instant crash.
Sarm seems to think its my drivers causing the problem and I can get the old verson.


If you updated your video drivers right before this started happening, I'd definitely roll them back to the previous version that you had, and see if that fixes the problem.

Re: Today hates me I swear

PostPosted: Thu Mar 22, 2012 3:19 pm
Author: Nighthawk4
I was joking about replacing Windows with Linux :lol:


Changing the drivers are most likely to solve the problem. A number of people have reported issues with some versions of drivers :wink:

Re: Today hates me I swear

PostPosted: Thu Mar 22, 2012 5:08 pm
Author: Gorgon
LadyAwesome wrote:What is Ubuntu?

And what does changing those .ini files actually do?

Because I cant even get to the movie part of the screen - it is instant crash.
Sarm seems to think its my drivers causing the problem and I can get the old verson.

Setting Client CPU Affinity=-2 under [Game Options] in nwnplayer.ini disables CPU Affinity to make the game use all available cores in a system with more than one core. Sometimes this helps with nwn (especially movie and sound problems). Many people suggest setting it to use only 1 core, but something other than the first one. The default Client CPU Affinity=0 makes the game use the first core, while setting it to 1 would make it use the second (and so on up to 31 for the 32nd core, if you are that lucky/rich ). Assuming you have a multicore system (most people do these days... except me), try -2 first (yes there is a minus before the 2), then try 1 to use the second core if that doesn't help. Leaving it set to 0 means you are sharing the 1st core with you OS and other apps that use it, so making nwn use another core can mean it isn't sharing it with as much other stuff (ok, not the most technical description, but good enough for this).

*side note* People who care can also set "CPU Affinity=-1" (*note the lack of "Client" in front of "CPU Affinity" in this case) in the nwtoolset.ini under [Start Up] , which should use all available cores on your cpu. You use -1, not -2 in that file to disable CPU Affinity (-1 in nwnplayer.ini will be converted to 0, and is why you use -2 there). You can also choose a single core other than the default (0), so it uses something other than the first core, the same way as the client setting above.

Setting NumCPUs=1 under [Processor] in nwnconfig.ini tells the game you have only 1 physical cpu (even if you don't - this is different than cores on cpus). You can have both multiple cpus and multiple cores on each cpu, so it can get a bit confusing (and why you can choose from 32 different cores above). Not many people have more than 1 cpu, other than hard core gamers, or higher end stuff. The server Avlis runs on (the beast) has 2 cpus with 4 cores each for example (according to the specs here).

For the movie crashing, you can also try editing nwn.ini and under [Display Options] set:
Disable Intro Movies=1
If you really must keep them, you can try changing SafeMovie=0 to SafeMovie=1 in the same location.
*edits* You can disable all movies (not just the intro ones) with Disable Movies=1 in the same location.

*updated to clarify the different "CPU Affinity" usage in the toolset.ini.

Re: Today hates me I swear

PostPosted: Fri Mar 23, 2012 10:42 pm
Author: Eklektikos
As suggested by Grunt in IRC:

http://pcsupport.about.com/od/windows7/ ... dows-7.htm

Should work under Vista also.

Re: Today hates me I swear

PostPosted: Fri Mar 23, 2012 10:47 pm
Author: Eklektikos
Failing that, here's a list of links to back-level AMD/ATI drivers:

32 bit Vista: http://support.amd.com/us/gpudownload/w ... sta32.aspx

64 bit Vista: http://support.amd.com/us/gpudownload/w ... sta64.aspx

Re: Today hates me I swear

PostPosted: Sat Mar 24, 2012 8:29 am
Author: Gumble Tinkertumble
Also you might try (if you haven't done so already) running the .exe in compatibility mode. If you right click on the icon and select properties, you should see a compatibility tab. Setting it for Windows XP SP3 might be the answer.

Re: Today hates me I swear

PostPosted: Mon Mar 26, 2012 10:47 am
Author: LadyAwesome
Was defiantly the video card YAAAAY its fixed! Boom.