Page 1 of 1

Handy master server bypass

PostPosted: Sun Oct 02, 2011 2:39 pm
Author: Ashan
Heres a simply way to avoid the master server delay that someone showed me!!!



Firstly, just to be safe; Ensure NWN's is closed down before you make this change. You should find like I have that after you make this change, you don't hang on the connecting stage and is instead instantaneous.

Okay the first step is to find your hosts file. (So you know where it is)

Step 1. Navigate from your root directory like C drive:
windows > system32 > drivers > etc > hosts (no extension)

If you're using Vista or Windows 7:
Open notepad up alone as an administrator. (Right click notepad and "open as administrator")
And then go File > Open: And navigate again through Step 1. to the 'hosts' file.

Everyone else (XP): Simply open hosts with notepad after you've located it (No need for running as administrator).


What you're faced with should look something like this:

CODE: SELECT ALL
# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

# localhost name resolution is handled within DNS itself.
# 127.0.0.1 localhost
# ::1 localhost



It's as simple as adding this line at the bottom of it:

CODE: SELECT ALL
0.0.0.0 nwmaster.bioware.com



Then click save without changing the name or extension in any way.


Yay no more waiting for the server to connect to a non exstiant server!

Re: Handy master server bypass

PostPosted: Sun Oct 02, 2011 2:43 pm
Author: Cameron Klym
Thats way KOOL man!Thanks!

Re: Handy master server bypass

PostPosted: Sun Oct 02, 2011 4:11 pm
Author: Grunt
"CODE: SELECT ALL" isn't needed in this case, just the line with:
0.0.0.0 nwmaster.bioware.com

You'll still get the "Could not contact Master Server" message, but it'll be instantaneous. Works well enough!

Re: Handy master server bypass

PostPosted: Sun Oct 02, 2011 4:15 pm
Author: gutemensch
In Windows 7 x64 I had to do a bit more than just 'open as administrator'. Navigate to location with your favorite file browser and bring up the props of Host. I had to unchecked read only and under user permission give myself full control for a moment (even through I am Admin).

Re: Handy master server bypass

PostPosted: Sun Oct 02, 2011 4:32 pm
Author: Gorgon
Resetting it to "read only" after you are done saving is a good idea btw.

Re: Handy master server bypass

PostPosted: Sun Oct 02, 2011 5:20 pm
Author: gutemensch
I did forget to include I reset it read only and revoked full control.

Re: Handy master server bypass

PostPosted: Sun Oct 02, 2011 5:27 pm
Author: Talwin Hawkins
Like.

Re: Handy master server bypass

PostPosted: Sun Oct 02, 2011 5:55 pm
Author: Eal
works like a charm

Re: Handy master server bypass

PostPosted: Sun Oct 02, 2011 6:22 pm
Author: Quinkish
I can't seem to get this working for NWN. I used this trick for bypassing the NWN2 server back in August, now I tried to add NWN to the host file and it doesn't affect it. Fortunately, NWN2 is still working right ... it's a neat trick.

Re: Handy master server bypass

PostPosted: Sun Oct 02, 2011 7:32 pm
Author: krackq
This thread = win!

The delay is annoying, especially when crashing out during an event or middle of a big fight!

Re: Handy master server bypass

PostPosted: Sun Oct 02, 2011 8:38 pm
Author: Blizzow
It's magic!

Re: Handy master server bypass

PostPosted: Sun Oct 02, 2011 9:09 pm
Author: Gumble Tinkertumble
That's brilliant!

Re: Handy master server bypass

PostPosted: Sun Oct 02, 2011 9:25 pm
Author: Nighthawk4
Didn't work on my Mac unfortunately :cry:

Re: Handy master server bypass

PostPosted: Sun Oct 02, 2011 9:34 pm
Author: Grunt
Nighthawk4 wrote:Didn't work on my Mac unfortunately :cry:


http://support.apple.com/kb/TA27291 ...might help? Not sure.

Re: Handy master server bypass

PostPosted: Mon Oct 03, 2011 6:47 am
Author: badjabadjabadja
Does what it says on the tin :)

(For Win XP anyway!)

:rate10:

Re: Handy master server bypass

PostPosted: Sat Oct 08, 2011 1:09 am
Author: maxinion
Nighthawk4 wrote:Didn't work on my Mac unfortunately :cry:


open terminal

sudo vim /etc/hosts

put in the lines that they said, following the formal in that file

save, quit, done

Re: Handy master server bypass

PostPosted: Sat Oct 08, 2011 5:55 am
Author: S_N
Neat quirk for windows, buf for linux (and I suspect mac too) 0.0.0.0 still a valid address that resolves to localhost. http://en.wikipedia.org/wiki/Default_route

however:
ping 0.0.0.n
where n is any number 1,2,3, ... 255 does result in 'connect: invalid argument' error message. And indeed, applying the trick described in the first post but with, for instance, 0.0.0.1 instead of 0.0.0.0 will make it work on linux as well. I find it likely that Mac would work the same way.

------ Option 2 -------

If it still doesn't work, then another, more proper imho, way to solve this is to configure iptables (or your firewall) to block outgoing connections to nwmaster.bioware.com. For linux with iptables this would be done like:

echo 127.0.42.199 nwmaster.bioware.com >> /etc/hosts
iptables -I OUTPUT -p all --dst nwmaster.bioware.com -j REJECT --reject-with icmp-host-prohibited


The binding to a dummy local ip would remove the possibility that DNS records change the ip-address of nwmaster.bioware.com in the future.

Test it out, and then make the iptables rule permanent.
iptables-store can write the current rules to configuration file format, and your current configuration might reside in /etc/sysconfig/

Re: Handy master server bypass

PostPosted: Wed Oct 26, 2011 1:26 pm
Author: badjabadjabadja
Mhmm.. mine stopped working a few days ago, and upon checking the hosts file realised the entry had disappeared!

Set it to read only now :D

Re: Handy master server bypass

PostPosted: Sat Jan 07, 2012 5:12 pm
Author: Li'll Divvil
Little additional tip, make sure your virus scanner is set to allow changes to your "hosts" file

Mine blocked it and would only allow a save as txt file which doesn't work.

You can change the VS back after you make the change.

Re: Handy master server bypass

PostPosted: Sat Jan 07, 2012 7:04 pm
Author: Talwin Hawkins
This only ever worked for a little while then reverted back. I tried to set it to read only like Badja said but no luck.

Re: Handy master server bypass

PostPosted: Sat Jan 07, 2012 7:24 pm
Author: Ashan
Really? its working for me since i did it first off

Re: Handy master server bypass

PostPosted: Sun Jan 08, 2012 6:03 pm
Author: S_N
Ashan: Does it also work for you if you put an invalid ip?
If so, it would be better to use one of those in your instead of 0.0.0.0 in the example above.

0.0.0.0. is special and goes to wherever the system (or network driver) decides the default route is (and therefore results may vary). For me it was the deferred to localhost, which caused it to time out exactly the same as bioware's server would.

Using any other ip address of the pattern 0.x.x.x should fail the requirement that A-class networks cannot have a zero address. (and hence probably not wait to time out)

Re: Handy master server bypass

PostPosted: Sun Jan 08, 2012 8:10 pm
Author: gutemensch
Might try setting it your router address. I've done that to a few things cause I hate programs that want to call home every time I start them up.

Re: Handy master server bypass

PostPosted: Mon Jan 09, 2012 1:25 am
Author: badjabadjabadja
My anti-virus (Comodo) detected the changes as a threat and deleted it (even when set to read only). I've since instructed it to ignore it, and is working fine now.

Re: Handy master server bypass

PostPosted: Mon Jan 09, 2012 8:12 am
Author: Talwin Hawkins
badjabadjabadja wrote:My anti-virus (Comodo) detected the changes as a threat and deleted it (even when set to read only). I've since instructed it to ignore it, and is working fine now.


That will be my problem as well. I will try that later.